#Excel – Un CERCA.VERT senza errori #N/D

Se si desidera nascondere gli errori #N/D generati dalla funzione CERCA.VERT quando non riesce a trovare un valore, si utilizza la funzione SE.ERRORE, che consente di intercettare l’errore e restituire un valore fornito.

Quando CERCA.VERT non riesce a trovare un valore nella tabella di ricerca, restituisce l’errore #N/D. La funzione SE.ERRORE permette di cogliere gli errori e restituire un proprio valore personalizzato quando si dovesse verificare un errore. Se CERCA.VERT restituisce un valore normale, non vi è alcun errore e SE.ERRORE restituisce quel valore. Se CERCA.VERT dovesse restituire l’errore #N/D, SE.ERRORE prenderebbe il sopravvento restituendo il valore fornito.

Se avete il valore da cercare nella cella A1 e la tabella di ricerca in un intervallo denominato “tabella”, e volete che la cella rimanga vuota quando non venisse trovata alcuna corrispondenza, è possibile utilizzare:

=SE.ERRORE(CERCA.VERT(A1; tabella; 2; FALSO); "")

Se, invece, volete che allorquando non venisse trovata nessuna corrispondenza, venga restituito il messaggio “Non trovato”, utilizzate:

=SE.ERRORE(CERCA.VERT(A1; tabella; 2; FALSO); "Non trovato")

Nelle versioni precedenti di Excel, che non hanno la funzione SE.ERRORE, è necessario ripetere la funzione CERCA.VERT all’interno della funzione SE:

=SE(VAL.NON.DISP(CERCA.VERT(A1; tabella; 2; FALSO)); "";CERCA.VERT(A1; tabella; 2; FALSO))

 

My Agile Privacy
Questo sito utilizza cookie tecnici e di profilazione. Cliccando su accetta si autorizzano tutti i cookie di profilazione. Cliccando su rifiuta o la X si rifiutano tutti i cookie di profilazione. Cliccando su personalizza è possibile selezionare quali cookie di profilazione attivare.
Attenzione: alcune funzionalità di questa pagina potrebbero essere bloccate a seguito delle tue scelte privacy
     Scarica il nostro ebook gratuito     

Unisciti ai 30.000+ sottoscrittori
della nostra mailing list
e scarica l'ebook con i
migliori trucchi e suggerimenti per Excel
selezionati per te da Excel Academy