INDICE – Scheda tecnica

SCOPO
Ottenere un valore da un intervallo o da una tabella in base alla posizione
SINTASSI
INDICE(matrice; riga; [col])
ARGOMENTI DELLA FUNZIONE
  • matrice – Un intervallo di celle, o una costante di matrice
  • riga – La posizione della riga nel riferimento o nella matrice
  • col – [Opzionale] La posizione della colonna nel riferimento o nella matrice
NOTE DI UTILIZZO

Utilizzate la funzione INDICE per ottenere un valore da un intervallo o da una tabella in base alla posizione. Ad esempio, la formula =INDICE(A1:B5;2;2) restituisce il valore contenuto nella cella B2.

La funzione INDICE ha due forme: per matrice e per riferimento.

Forma per matrice

Nella forma per matrice di INDICE, il primo parametro è una matrice, che viene fornita come un intervallo di celle o una costante di matrice. La sintassi della forma per matrice di INDICE è:

INDICE(matrice; riga; [col])
  • Se sia riga che col sono fornite, INDICE restituisce il valore nella cella all’intersezione di riga e col.
  • Se riga è impostato a zero, INDICE restituisce una matrice di valori per l’intera riga. Per utilizzare questi valori di matrice, occorre inserire la funzione INDICE come formula matriciale (con Ctrl + Maiusc + Invio) in un intervallo orizzontale
  • Se col è impostato a zero, INDICE restituisce una matrice di valori per l’intera colonna. Per utilizzare questi valori di matrice, occorre inserire la funzione INDICE come formula matriciale (con Ctrl + Maiusc + Invio) in un intervallo verticale.

Forma per riferimento

Nella forma per riferimento di INDICE, il primo parametro è rif, che viene fornito come un riferimento a uno o più intervalli di celle. La sintassi della forma per riferimento di INDICE è:

INDICE(rif; riga; [col]; [area])
  • La forma per riferimento di INDICE restituisce il riferimento della cella all’incrocio tra riga e col
  • Se rif è fornito come intervalli multipli, area indica quale intervallo utilizzare
  • area viene fornito come un numero. Ad esempio, nella formula =INDICE((A1:C5; A7:C10); 2;2;2), area viene fornito come 2, che si riferisce all’intervallo A7:C10.
SCHERMATE ESEMPLIFICATIVE

 

ERRORI
  • #RIF! – Si verifica se:
    • l’argomento riga fornito è maggiore del numero di righe presenti nell’intervallo fornito (matrice);
    • l’argomento col fornito è maggiore del numero di colonne presenti nell’intervallo fornito;
    • l’argomento area fornito è maggiore del numero di aree presenti nell’intervallo fornito.
  • #VALORE! – Si verifica se uno degli argomenti riga, col o area non sono valori numerici.
LINK ALLA GUIDA IN LINEA DI OFFICE
My Agile Privacy
Questo sito utilizza cookie tecnici e di profilazione. Cliccando su accetta si autorizzano tutti i cookie di profilazione. Cliccando su rifiuta o la X si rifiutano tutti i cookie di profilazione. Cliccando su personalizza è possibile selezionare quali cookie di profilazione attivare.
Attenzione: alcune funzionalità di questa pagina potrebbero essere bloccate a seguito delle tue scelte privacy
     Scarica il nostro ebook gratuito     

Unisciti ai 30.000+ sottoscrittori
della nostra mailing list
e scarica l'ebook con i
migliori trucchi e suggerimenti per Excel
selezionati per te da Excel Academy