Mantenere la formattazione durante la concatenazione

Quando utilizza una formula per unire il contenuto di più celle in una cella unica, Cristina ha problemi a fare in modo che Excel preservi la formattazione delle celle originali. Ad esempio, supponiamo che le celle A1 e B1 contengano rispettivamente 1 e 0,33. Nella cella C1, inserisce la seguente formula:

=A1 & " : " & B1

Il risultato nella cella C1 è simile al seguente:

1:0.3333333333

Il motivo per cui il risultato in C1 non corrisponde a quanto mostrato in B1 (0,33) è perché il valore in B1 non è realmente 0,33. Internamente, Excel mantiene i valori a 15 cifre, in modo che se la cella B1 contiene una formula come =1/3, internamente il risultato viene mantenuto con la massima precisione. Ciò che vedi nella cella B1, tuttavia, dipende da come è formattata la cella. In questo caso, la formattazione è probabilmente impostata per visualizzare solo due cifre oltre la virgola decimale.

Tuttavia, esistono diversi modi per ottenere i risultati desiderati nella cella C1. Un metodo consiste semplicemente nel modificare leggermente la formula in modo che i valori estratti dalle celle A1 e B1 siano formattati. Ad esempio, l’esempio seguente utilizza la funzione TESTO per eseguire la formattazione:

=TESTO(A1;"0") & " : " & TESTO(B1;"0.00")

In questo caso, A1 è formattato per visualizzare solo numeri interi e B1 è formattato per visualizzare solo due cifre decimali. Puoi anche usare la funzione ARROTONDA per ottenere un risultato simile:

=ARROTONDA(A1;0) & " : " & ARROTONDA(B1;2)

Un’altra possibile soluzione è modificare il modo in cui Excel gestisce la precisione nella cartella di lavoro. Segui questi passaggi:

  1. Visualizza la finestra di dialogo Opzioni di Excel (in Excel 2007 fai clic sul pulsante Office e quindi su Opzioni di Excel. In Excel 2010 o versioni successive, visualizza la scheda File della barra multifunzione e quindi fai clic su Opzioni).
  2. Fai clic sull’opzione Impostazioni avanzate a sinistra della finestra di dialogo.
  3. Scorri le opzioni disponibili fino a visualizzare la sezione Durante il calcolo della cartella di lavoro.
  4. Assicurati che la casella di controllo Imposta approssimazione come visualizzata sia selezionata.
  5. Fai clic su OK.
Mantenere la formattazione durante la concatenazione 1
  1. Excel ci avvisa che i dati perderanno precisione

Ora, Excel utilizza la precisione mostrata sullo schermo in tutti i suoi calcoli e concatenazioni invece di eseguire calcoli con la precisione completa di 15 cifre come normalmente fa. Sebbene questo approccio possa essere accettabile per alcuni utenti, per altri presenterà più problemi di quanti ne risolva. Dovrai determinare se puoi vivere con una precisione inferiore per ottenere l’output formattato nel modo che preferisci.

Un altro approccio ancora è quello di creare una propria funzione definita dall’utente (UDF) che restituirà ciò che viene visualizzato per la cella di destinazione, piuttosto che ciò che è memorizzato. La seguente macro funzionerà benissimo in questo senso:

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

E puoi interromperlo in ogni momento e in completa autonomia.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Per utilizzare questa macro, dovrai utilizzare una formula come questa nel tuo foglio di lavoro:

=FmtText(A1) & " : " & FmtText(B1)
LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Tags: , , , , ,

Ti è stato utile?