Restituire una cella vuota quando la cella referenziata è vuota

Se hai una formula in un foglio di lavoro e la cella a cui fa riferimento la formula è vuota, la formula restituisce comunque un valore pari a zero. Ad esempio, se hai la formula =A3, la formula restituisce il contenuto della cella A3, a meno che la cella A3 non sia vuota. In tal caso, la formula restituisce un valore pari a zero.

Questo sembra essere correlato all’idea che è impossibile per una formula restituire un valore vuoto. Tuttavia, puoi espandere leggermente la tua formula in modo che restituisca una stringa vuota. Invece di usare =A3 come formula, dovresti usare quanto segue:

=SE(VAL.VUOTO(A3);"";A3)

Questa formula utilizza VAL.VUOTO, che restituisce Vero o Falso, a seconda che la cella di riferimento (A3) sia vuota o meno. La funzione SE restituisce quindi una stringa vuota (“”) se A3 è vuoto oppure utilizza il valore in A3 se A3 non è vuoto.

Indipendentemente da ciò che restituisce la formula, puoi comunque utilizzare il suo risultato in altre formule e funzionerà correttamente. Anche se restituisce una stringa vuota, viene comunque trattata da altre formule come se contenesse zero. Nelle aree in cui trattare la cella come se contenesse zero potrebbe essere problematico (come quando stai tracciando i risultati della formula), puoi modificare un po’ la formula, come mostrato qui:

=SE(VAL.VUOTO(A3);NON.DISP();A3)

Questa formula restituisce l’errore #N/D se A3 è vuoto. Questo errore si propaga attraverso altre formule che fanno riferimento alla formula, ma l’errore #N/D viene ignorato completamente durante la creazione di grafici.

Sebbene le soluzioni di cui sopra siano soddisfacenti per la maggior parte delle persone, alcune persone vorrebbero davvero vedere la cella di destinazione veramente vuota se la cella di origine è vuota. Ad esempio, potresti volere che la cella B7 sia vuota se la cella A3 è vuota. Se inserisci una formula nella cella B7 (come già discusso), la cella B7 non è veramente vuota: contiene una formula.

Se questo è il tuo obiettivo, il vero “vuoto”, puoi raggiungerlo solo attraverso l’uso di una macro. La macro dovrà verificare se la cella di origine è stata modificata. Se lo è stata, tutto ciò che è nell’origine deve essere copiato nella cella di destinazione.

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

E puoi interromperlo in ogni momento e in completa autonomia.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Tags: , , , , ,

Ti è stato utile?

Articolo precedente

Scambiare due celle