Sommare le singole cifre presenti in una cella

Se hai una cella che contiene un valore, potresti voler escogitare un modo per sommare tutte le cifre nel valore. Ad esempio, se una cella contiene il valore 554, potresti voler determinare la somma di 5+5+4, che è 14, oppure di una cella contenente “D45F12” potresti voler sommare 4+5+1+2 per ottenere 12.

Ci sono diversi modi per affrontare questo compito (in realtà, è sempre così in Excel). Il primo è usare una formula che si basa su diverse funzioni:

=SOMMA(SE.ERRORE(--STRINGA.ESTRAI(A1;RIF.RIGA(INDIRETTO("1:"&LUNGHEZZA(A1)));1);))

Si tratta di una formula da inserire in forma di matrice, quindi con CTRL+MAIUSC+INVIO piuttosto che con l’Invio semplice.

La formula presuppone che la cella con le cifre da sommare sia A1.

È inoltre possibile utilizzare una funzione definita dall’utente (UDF) per restituire la somma desiderata. La seguente macro passa attraverso ogni cifra nella cella di riferimento e calcola un totale. Questo valore viene quindi restituito all’utente:

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , , , , , , , ,

Ti è stato utile?