Identificare le celle che contengono caratteri non numerici

Christian ha un gran numero di celle che contengono in parte numeri. Queste celle possono contenere cifre o lettere, in qualsiasi combinazione. Possono anche contenere caratteri speciali come trattini, barre e spazi. Chris ha bisogno di un modo per identificare se una cella contiene solo cifre, senza prendere in considerazione i caratteri speciali. Pertanto, una cella contenente 123-45 verrebbe visualizzata come contenente solo cifre, mentre 123AB-45 no.

Il modo più semplice per capire se una determinata cella contiene solo i caratteri e le cifre consentiti consiste nell’utilizzare una formula che rimuova i caratteri speciali consentiti, e quindi verifica se il valore risultante è numerico. Tutte le seguenti formule possono funzionare abbastanza bene:

=SE(SE.ERRORE(INT(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI(A1;"-"; "");"/"; "");" "; ""));FALSO); VERO; FALSO)
=O(VAL.NUMERO(SOSTITUISCI(A1;"-";"")+0);VAL.NUMERO(SOSTITUISCI(A1;"/";"")+0);VAL.NUMERO(SOSTITUISCI(A1;" ";"")+0))
=VAL.NUMERO(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI(A1;" ";"");"/";"");"-";"")*1)

Puoi anche usare una semplice macro (UDF) per capire se una cella contiene solo cifre e i caratteri consentiti. Sebbene ci siano molti modi in cui è possibile avvicinarsi a tale macro, ecco un metodo piuttosto semplice:

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , , , , , , ,

Ti è stato utile?