Sommare solo le celle contenenti formule

Michele si chiede se esista un modo per sommare un intervallo di dati e includere nella somma solo quelle celle che contengono una formula. Secondo le esigenze di Michele, se una cella contiene un valore esplicito e non una formula, non dovrebbe essere inclusa nella somma.

Ci sono molti modi in cui potresti ottenere il risultato desiderato, ma mi concentrerò solo su alcuni di essi.

Innanzitutto, se hai bisogno di determinare la somma una sola volta e non farla apparire all’interno del foglio di lavoro, puoi seguire questi passaggi:

  1. Seleziona le celle che vuoi sommare.
  2. Premi F5. Excel visualizza la finestra di dialogo Vai a.
  3. Fai clic sul pulsante Speciale. Excel visualizza la finestra di dialogo Vai a formato speciale.
  4. Seleziona il pulsante di opzione Formule.
  5. Fai clic su OK. Excel modifica le celle selezionate in modo che vengano selezionate solo quelle contenenti formule.

A questo punto puoi guardare nella barra di stato (nella parte inferiore della finestra di Excel) e vedere la somma delle celle selezionate, quelle che contengono le formule.

Se preferisci un approccio basato su formule, uno dei fattori chiave qui sarà la versione di Excel che stai utilizzando. Microsoft ha introdotto la funzione VAL.FORMULA con il rilascio di Excel 2013, quindi se si utilizza quella versione (o successiva), determinare la somma desiderata è abbastanza semplice. Basta usare questa formula:

=MATR.SOMMA.PRODOTTO(A1:A5;--VAL.FORMULA(A1:A5))

Questa formula presuppone che l’intervallo di dati che si desidera sommare sia A1:A5. Il segno “doppio negativo” prima della funzione VAL.FORMULA viene utilizzato per convertire i valori VERO e FALSO (come restituiti da VAL.FORMULA) in 1 o 0.

Se preferisci utilizzare una formula di matrice, puoi utilizzare la seguente formula:

=SOMMA(SE(VAL.FORMULA(A1:A5);A1:A5))

oppure

=SOMMA(VAL.FORMULA(A1:A5)*A1:A5)

Ricorda solo di inserirla usando Ctrl + Maiusc + Invio e otterrai il risultato corretto.

Se stai utilizzando una versione di Excel precedente a Excel 2010, queste formule non funzioneranno. Dovrai, invece, fare affidamento su una funzione definita dall’utente (UDF) per svolgere il compito:

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

E puoi interromperlo in ogni momento e in completa autonomia.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , ,

Ti è stato utile?