Come convertire un intervallo di URL in collegamenti ipertestuali

Giovanni ha una cartella di lavoro che contiene oltre un migliaio di URL, tutti nella colonna A. Questi non sono collegamenti ipertestuali; sono semplice testo di singoli URL. Giovanni desidera convertire gli URL in collegamenti ipertestuali attivi, ma eseguire la conversione individualmente è estremamente noioso, soprattutto per così tanti URL.

Un modo per eseguire la conversione è utilizzare la funzione COLLEG.IPERTESTUALE. Inserisci questa formula nella cella B1 e copiala in tutte le celle necessarie:

=SE(A1="";"";COLLEG.IPERTESTUALE(SE(SINISTRA(A1;7)="http://";"";"http://")&A1))

 

Il risultato è che la colonna B conterrà collegamenti ipertestuali per tutto ciò che si trova nella colonna A. La formula non è particolarmente robusta, poiché controlla solo la presenza o la mancanza del testo “http://”, e potresti voler gestire anche indirizzi con “https”. È possibile modificare la formula (ovvero renderla più complessa), ma potresti anche prendere in considerazione l’utilizzo di una macro per eseguire le conversioni.

Per essere efficace, la macro dovrebbe scorrere ciascuna cella in un intervallo selezionato e, se la cella non è vuota, convertire il contenuto in un collegamento ipertestuale. Quanto segue svolgerà il compito:

 

Sub URL_List()
    Dim sTemp As String
    Dim sURL As String
    Dim cell As Range
    For Each cell In Selection
        If cell.Value <> "" Then
            sTemp = Left(cell.Value, 7)
            If sTemp = "http://" Or sTemp = "https:/" Then
                sURL = cell.Value
            Else
                sURL = "http://" + cell.Value
            End If
            ActiveSheet.Hyperlinks.Add Anchor:=cell, _
              Address:=sURL, TextToDisplay:=cell.Value
        End If
    Next cell
End Sub

 

 

La macro non è infallibile; si presuppone che, se una cella contiene qualcosa, sia un URL valido. Ciò che fa è controllare il contenuto della cella e, se il contenuto non è preceduto dal testo “http://” o “https:/”, viene aggiunto il prefisso “http://”. Il collegamento ipertestuale viene quindi creato in base al contenuto della cella.

 

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

 

 

Tags: , , , , , , , , ,

Ti è stato utile?