Determinare la più lunga sequenza di numeri negativi

Lorenzo ha una serie di numeri, in celle adiacenti, che possono essere positivi o negativi. Vorrebbe un modo per determinare la più lunga sequenza di numeri negativi nell’intervallo. Quindi, se ci fossero sette numeri negativi in ​​file, vorrebbe una formula che restituisse il valore 7.

Ci siamo spremuti un po’ le meningi, ma non abbiamo trovato una sola formula che possa fare ciò che vogliamo. Puoi, tuttavia, farlo con una colonna intermedia. Ad esempio, se hai i tuoi numeri nella colonna A (che iniziano in A1), puoi inserire la seguente formula nella cella B1:

=SE(A1<0;1;0)

Quindi, nella cella B2 inserisci quanto segue:

=SE(A2<0;B1+1;0)

Copialo su tutte le altre celle nella colonna B per le quali è presente un valore nella colonna A. Quindi, in una cella diversa (ad esempio, la cella C1) puoi inserire la seguente formula:

=MAX(B:B)

Questo valore rappresenterà il maggior numero di valori negativi consecutivi nella colonna A.

Se non vuoi creare una colonna intermedia per ottenere la risposta, puoi creare una funzione definita dall’utente (UDF) come la seguente che restituirà il valore.

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

E puoi interromperlo in ogni momento e in completa autonomia.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Tags: , , ,

Ti è stato utile?