Contare le virgole presenti in un intervallo

Al lavoro, Marco deve regolarmente contare il numero di virgole in un intervallo di celle selezionate. Non riesce a trovare una funzione di Excel per eseguire questo tipo di attività e si chiede se una macro potrebbe essere in grado di svolgere il compito.

Sebbene non vi sia alcuna funzione specifica che produca il conteggio desiderato, è possibile utilizzare una o due formule. Se vuoi solo conoscere il numero di celle che contengono almeno una virgola, la seguente formula funzionerà perfettamente:

=CONTA.SE(A1:A10;"*,*")

Se, invece, hai bisogno di capire il numero di virgole nell’intervallo quando potrebbero esserci più virgole per cella, allora devi usare una formula diversa:

=SOMMA(LUNGHEZZA(A1:A10))-SOMMA(LUNGHEZZA(SOSTITUISCI(A1:A10;",";"")))

Ovviamente dovrai modificare gli intervalli delle celle da verificare nelle due posizioni della formula, in modo che si adatti alle tue necessità.

Se preferisci, puoi anche creare una funzione definita dall’utente (UDF) per contare il numero di virgole. Ci sono diversi modi per affrontare un tale compito; quello che segue è solo un esempio.

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , , , , , ,

Ti è stato utile?