Trovare i valori dispari maggiori di 50

Enrico ha 1.000 valori in un foglio di lavoro Excel, che occupano 100 righe per 10 colonne. Ogni valore in questo intervallo è un valore intero compreso tra 0 e 99. Enrico ha bisogno di un modo per contare e visualizzare tutti i valori dispari e maggiori di 50.

Ci sono alcuni modi in cui puoi contare e visualizzare, ma è importante capire che si tratta di attività diverse. Forse il modo migliore per visualizzare quei valori che soddisfano i criteri è utilizzare la formattazione condizionale. Puoi aggiungere una regola di formattazione condizionale a ciascuna cella che evidenzierà i valori desiderati. Segui questi passi:

  • Seleziona le celle che contengono i tuoi dati
  • Visualizza la scheda Home della barra multifunzione
  • Fai clic sullo strumento Formattazione condizionale nel gruppo Stili. Excel visualizza una tavolozza di opzioni relative alla formattazione condizionale
  • Fai clic su Nuova regola. Excel visualizza la finestra di dialogo Nuova regola di formattazione (vedi Figura)
Trovare i valori dispari maggiori di 50 1
  • Nell’area Selezionare un tipo di regola nella parte superiore della finestra di dialogo, scegli Utilizza una formula per determinare le celle da formattare
  • Nella casella della formula inserisci la formula =E(RESTO(A1;2);A1>50).
  • Fai clic sul pulsante Formato. Excel visualizza la finestra di dialogo Formato celle
  • Utilizza i controlli nella finestra di dialogo per modificare la formattazione, come desideri
  • Fai clic su OK per chiudere la finestra di dialogo Formato celle
  • Fai clic su OK per chiudere la finestra di dialogo Nuova regola di formattazione. La formattazione viene applicata all’intervallo di celle selezionato nel passaggio 1.

Se preferisci, puoi anche utilizzare la seguente come formula da inserire nella formattazione condizionale:

=E(VAL.DISPARI(A1);A1>50)

Per ottenere il conteggio delle celle che soddisfano i criteri, puoi utilizzare una formula di matrice:

=SOMMA(RESTO(Dati;2)*(Dati>50))

Questa formula presuppone che l’intervallo di celle che si desidera analizzare sia denominato Dati. Non dimenticare di inserire la cella usando Ctrl+Maiusc+Invio. Se non si desidera utilizzare una formula di matrice, è possibile utilizzare la seguente:

=MATR.SOMMA.PRODOTTO(RESTO(Dati;2)*(Dati>50))

Puoi anche usare una macro sia per evidenziare le celle che per il conteggio. Quella che segue è una versione di tale macro.

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , , , ,

Ti è stato utile?