Estrarre i numeri che sono tra un valore minimo e un valore massimo

Roberto ha una serie di numeri nella colonna A che vanno da 1 a 100. Vorrebbe estrarre solo i valori compresi tra 65 e 100, inclusi, e inserirli nella colonna B. Si chiede se c’è un modo per farlo facilmente.

La risposta breve è che esiste un modo molto semplice per farlo, a condizione che non ti dispiaccia ordinare l’elenco dei numeri. Segui questi passaggi:

  1. Seleziona una cella nella colonna A (non importa quale cella selezioni, purché sia ​​una delle celle che contiene un numero)
  2. Visualizza la scheda Dati della barra multifunzione.
  3. Fai clic sullo strumento Ordina dalla A alla Z, nel gruppo Ordina e filtra. Excel ordina tutti i numeri nella colonna.
  4. Seleziona i numeri che vuoi inserire nella colonna B.
  5. Premi Ctrl+X per tagliare le celle negli Appunti
  6. Seleziona la cella B1 (o la prima cella nella colonna B in cui desideri che vengano visualizzati i valori)
  7. Premi Ctrl+V per incollare le celle nella colonna

Questo è tutto; Ora hai le celle desiderate nella colonna B. Se volevi semplicemente copiare le celle, nel passaggio 5 avresti potuto premere Ctrl+C invece di Ctrl+X.

Se è necessario mantenere i valori di colonna A nel loro ordine originale (meno i valori che desideri spostare), è possibile farlo utilizzando la colonna B come colonna “segnaposto”. A destra del primo valore nella colonna A, inserisci il valore 1. Quindi, sotto quello nella colonna B, inserisci un 2, quindi un 3 e così via, finché ogni valore nella colonna A ha un valore corrispondente nella colonna B che indica La posizione dei numeri. Quindi, segui questi passaggi:

  1. Seleziona una cella nella colonna A (non importa quale cella selezioni, purché sia ​​una delle celle che contiene un numero)
  2. Visualizza la scheda Dati della barra multifunzione
  3. Fai clic sullo strumento Ordina dalla A alla Z, nel gruppo Ordina e filtra. Excel ordina tutti i numeri nella colonna.
  4. Seleziona i numeri nella colonna A che vuoi spostare, insieme ai numeri a destra di essi in colonna B
  5. Premi Ctrl+X per tagliare le celle negli Appunti
  6. Seleziona la cella D1 (è importante selezionare la cella D1 perché è necessario lasciare vuota la colonna C)
  7. Premi Ctrl+V per incollare le celle nelle colonne D ed E
  8. Seleziona una cella nella colonna B
  9. Visualizza la scheda Dati della barra multifunzione.
  10. Fai clic sullo strumento Ordina dalla A alla Z, nel gruppo Ordina e filtra. Excel ordina tutti i numeri nella colonna in base ai valori nella colonna B
  11. Seleziona una cella nella colonna E
  12. La scheda Dati della barra multifunzione dovrebbe essere ancora visualizzata
  13. Fai clic sullo strumento Ordina dalla A alla Z, nel gruppo Ordina e filtra. Excel ordina tutti i numeri nella colonna in base ai valori nella colonna E
  14. Elimina le colonne B, C ed E.

A questo punto i valori nelle colonne A e B riflettono il loro ordine originale, di quando erano tutti nella colonna A.

Un altro modo per spostare le celle consiste nell’utilizzare le funzionalità di filtro di Excel. Segui questi passaggi:

  1. Seleziona una cella nella colonna A (non importa quale cella selezioni, purché sia ​​una delle celle che contiene un numero)
  2. Visualizza la scheda Dati della barra multifunzione
  3. Fai clic sullo strumento Filtro. Excel aggiunge una freccia a discesa sul lato destro dell’intestazione della colonna A
  4. Fai clic sulla freccia in basso e seleziona Filtri per numeri > Tra. Excel visualizza la finestra di dialogo Personalizza filtro automatico
  5. Nella casella “è maggiore o uguale a“, immetti 65
  6. Nella casella “è minore o uguale a“, immetti 100
  7. Fai clic su OK. Excel limita ciò che viene mostrato solo alle righe che soddisfano i criteri specificati nei passaggi da 4 a 6
  8. Seleziona le celle che vengono visualizzate
  9. Premi Ctrl+C per copiare le celle negli Appunti.
  10. Seleziona la cella B1 (o la prima cella nella colonna B in cui desideri che vengano visualizzati i valori)
  11. Premi Ctrl+V per incollare le celle nella colonna
  12. Seleziona una delle celle nella colonna A
  13. Fai nuovamente clic sullo strumento Filtro (la scheda Dati della barra multifunzione dovrebbe essere ancora visualizzata). Excel rimuove il filtro applicato in precedenza.

Puoi anche utilizzare le formule, in colonna B, per estrarre i valori che rientrano nell’intervallo desiderato. Un modo semplice per farlo è inserire questa formula nella cella B1:

=SE(E(A1>=65; A1<=100);A1;"")

Copia la formula lungo la colonna B e ti ritroverai con qualsiasi valore nell’intervallo da 65 a 100, inclusi, “copiato” nella colonna B. Se il valore è al di fuori di questo intervallo, la cella nella colonna B viene lasciata vuota.

Supponendo che non si desiderino celle vuote nella colonna B, è possibile utilizzare una formula di matrice per acquisire i valori. Se i tuoi valori sono nell’intervallo A1:A500, inserisci quanto segue nella cella B1:

=SE.ERRORE(INDICE(A$1:A$500;PICCOLO(SE(A$1:A$500>=65;RIF.RIGA($1:$500));RIF.RIGA()));"")

Inseriscilo usando Ctrl + Maiusc + Invio, quindi copia la formula verso il basso fin dove desideri.

Ci sono, ovviamente, anche soluzioni basate su macro che puoi usare. Queste sono utili se è necessario eseguire questa attività spesso con i dati che si recuperano da una fonte esterna. Quello che segue è un semplice esempio di macro che potresti usare:

Questo contenuto è riservato agli abbonati

Solo gli utenti con Abbonamento VBA Coder oppure Ultimate possono visionarlo.

Se sei già abbonato Accedi per sbloccare il contenuto!

In caso contrario abbonati qui! L'abbonamento è conveniente.

E puoi interromperlo in ogni momento e in completa autonomia.

(puoi renderti conto di quanti siano i contenuti riservati

raggiungendo questa pagina)

Tags: , , , , , , ,

Ti è stato utile?